$re = '/\[\]|\[.+?\]|$/';
$str = '[]
[34143432]
dsadsad[343]43342dasdsad
dasdsada[]32eq3eq3[]ewaewq
qweqwe[342dsa]342423423343[]dsada
dasdsadsadsa[]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);