const regex = /(?:\p{L}*(\p{L})\P{L}+(?=\1))+\p{L}+/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\p{L}*(\\p{L})\\P{L}+(?=\\1))+\\p{L}+', 'gmi')
const str = `word !dark,123 king... glow__we 3end hello bye low3 ?wing`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}