import re
regex = re.compile(r"^[Hh]eading\t(\d+)\t[\d\.]+\t(.+)", flags=re.MULTILINE)
test_str = ("heading 1 0. References\n"
"heading 1 1. Introduction\n"
"heading 1 2. System of interest: heavy component\n"
"heading 2 2.1 Definition and role of the heavy component\n"
"heading 3 2.1.1 General Definitions\n"
"heading 3 2.1.2 heavy component main missions\n"
"heading 11 2.1.1.11.3.4 Generic chapter\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")