import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/(dev-|stag-)?(assets|images)\\.server\\.io\\/v\\d\\/file\\/(.*?)\\/(?!download$)[^\\/]+$";
final String string = "https://assets.server.io/v3/file/blt123e25b85f95497/download.jpg\n"
+ "https://images.server.io/v3/file/blt123e25b85f95497/download\n"
+ "https://images.server.io/v3/file/blt123e25b85f95497/random.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}