import re
regex = re.compile(r"^(?=(?:.*?[a-z]){5})(?=(?:.*?\d){4}).*", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("ffffasfsaf242343242\n"
"2vv4fj222\n"
"555553jjjjjj\n"
"fdsfafadsfdf\n"
"234234324232\n"
"4444fasdfasf\n"
"3j3j3j3j3j3\n"
"11111jjjjjnnn\n"
"ffffa888883j3j3j3j3j33j3j3j3j3j3411jjjjjnnn")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")