# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(“|”)/"/gm;t' <<< "“keyword 1” keyword2 “keyword 3” "