using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(;)";
string substitution = @"\n";
string input = @"1;John;Doe;45
2;jaja;dada;2";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}