package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z\d]+`)
var str = `abcdk436685
sdlisanrgl
sgvjsgvb
2345678990
#$%&*$#^#$&%^$*&
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}