import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>]*>";
final String string = " <li id=\"ctl00_LeftNavigation1_LeftMenu_ctl00_ListItem1\" class=\"starLink\"><a href='/CheatSheet.aspx'>Regex Cheat Sheet</a></li>\n"
+ " \n"
+ " <li id=\"ctl00_LeftNavigation1_LeftMenu_ctl02_ListItem1\"><a href='/Search.aspx'>Search</a></li>\n"
+ " \n"
+ " <li id=\"ctl00_LeftNavigation1_LeftMenu_ctl03_ListItem1\"><a href='/RETester.aspx'>Regex Tester</a></li>\n"
+ " \n"
+ " <li id=\"ctl00_LeftNavigation1_LeftMenu_ctl04_ListItem1\"><a href='/DisplayPatterns.aspx'>Browse Expressions</a></li>\n"
+ " \n"
+ " <li id=\"ctl00_LeftNavigation1_LeftMenu_ctl05_ListItem1\"><a href='/Add.aspx'>Add Regex</a></li>\n"
+ " \n"
+ " <li id=\"ctl00_LeftNavigation1_LeftMenu_ctl06_ListItem1\"><a href='/UserPatterns.aspx'>Manage My Expressions</a></li>\n"
+ " \n"
+ " <li id=\"ctl00_LeftNavigation1_LeftMenu_ctl07_ListItem1\"><a href='/Contributors.aspx'>Contributors</a></li>\n"
+ " \n"
+ " <li id=\"ctl00_LeftNavigation1_LeftMenu_ctl11_ListItem1\"><a href='/Resources.aspx'>Regex Resources</a></li>\n"
+ " \n"
+ " <li id=\"ctl00_LeftNavigation1_LeftMenu_ctl12_ListItem1\"><a href='/WebServices.asmx'>Web Services</a></li>\n"
+ " \n"
+ " <li id=\"ctl00_LeftNavigation1_LeftMenu_ctl13_ListItem1\"><a href='http://lakequincy.com/advertisers/publisherinfo/regExLib.aspx'>Advertise</a></li>\n"
+ " \n"
+ " <li id=\"ctl00_LeftNavigation1_LeftMenu_ctl14_ListItem1\"><a href='/Contact.aspx'>Contact Us</a></li>\n"
+ " \n"
+ " <li id=\"ctl00_LeftNavigation1_LeftMenu_ctl15_ListItem1\"><a href='/Register.aspx'>Register</a></li>\n"
+ " \n"
+ " <li id=\"ctl00_LeftNavigation1_LeftMenu_ctl16_ListItem1\" class=\"rssLink\"><a href='http://feeds.feedburner.com/Regexlibcom-RecentPatterns'>Recent Expressions</a></li>\n"
+ " \n"
+ " <li id=\"ctl00_LeftNavigation1_LeftMenu_ctl17_ListItem1\" class=\"rssLink\"><a href='http://feeds.feedburner.com/Regexlibcom-RecentComments'>Recent Comments</a></li>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}