# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\p{L}\p{M}*+)-\h(?=\p{L})/$1/gm;t' <<< "the sun was shin- ing and the sky bl- ue"