using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\p{L}\p{M}*+)-\h(?=\p{L})";
string substitution = @"$1";
string input = @"the sun was shin- ing and the sky bl- ue";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}