#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\$ABC(?!02$)[0-9]+$"
Local $sString = "$ABC01" & @CRLF & _
"$ABC02" & @CRLF & _
"$ABC03" & @CRLF & _
"$ABC04" & @CRLF & _
"$ABC05" & @CRLF & _
"$ABC0210"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")