import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(biovar)? *(?P<number>\\d+)?[, ]*(?P<addition>\\w+)?";
final String string = "biovar 1\n"
+ "?\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 3\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "3\n"
+ "3\n"
+ "6\n"
+ "7\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "3\n"
+ "3\n"
+ "6\n"
+ "3\n"
+ "?\n"
+ "1\n"
+ "1\n"
+ "4\n"
+ "2\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "3\n"
+ "3\n"
+ "3\n"
+ "1\n"
+ "1\n"
+ "9\n"
+ "?\n"
+ "6\n"
+ "6\n"
+ "1\n"
+ "2\n"
+ "1\n"
+ "1\n"
+ "?\n"
+ "3\n"
+ "1\n"
+ "1\n"
+ "3\n"
+ "1\n"
+ "2\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "3\n"
+ "3\n"
+ "3\n"
+ "?\n"
+ "2\n"
+ "2\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "2\n"
+ "9\n"
+ "?\n"
+ "?\n"
+ "4\n"
+ "3\n"
+ "5\n"
+ "5\n"
+ "?\n"
+ "1\n"
+ "9\n"
+ "6\n"
+ "2\n"
+ "?\n"
+ "6\n"
+ "3\n"
+ "1\n"
+ "1\n"
+ "?\n"
+ "3\n"
+ "?\n"
+ "1\n"
+ "3\n"
+ "2\n"
+ "?\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "2\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "2\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "biovar 1\n"
+ "?\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1a\n"
+ "biovar 1\n"
+ "biovar 1a\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 2\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "6\n"
+ "6\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "biovar 3\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "4\n"
+ "?\n"
+ "1\n"
+ "1\n"
+ "2, atypical\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1, atypical\n"
+ "4\n"
+ "2\n"
+ "2\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "3b\n"
+ "4\n"
+ "2\n"
+ "7\n"
+ "7\n"
+ "6\n"
+ "9\n"
+ "7\n"
+ "7\n"
+ "?\n"
+ "?\n"
+ "1\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "biovar 1\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "biovar 3\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "biovar 3\n"
+ "biovar 3\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 3\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "?\n"
+ "biovar Abortus\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "biovar 2\n"
+ "?\n"
+ "biovar 3\n"
+ "biovar 4\n"
+ "?\n"
+ "biovar 5\n"
+ "biovar 6\n"
+ "?\n"
+ "biovar 9\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "biovar 1\n"
+ "biovar 2\n"
+ "?\n"
+ "biovar 3\n"
+ "?\n"
+ "biovar 3\n"
+ "?\n"
+ "biovar 4\n"
+ "?\n"
+ "biovar 5\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "biovar I\n"
+ "biovar 2\n"
+ "biovar 2\n"
+ "biovar 2\n"
+ "biovar 2\n"
+ "biovar 2\n"
+ "biovar 2\n"
+ "biovar 2\n"
+ "biovar 4\n"
+ "biovar 4\n"
+ "biovar 4\n"
+ "biovar 4\n"
+ "biovar 4\n"
+ "biovar 4\n"
+ "biovar 4\n"
+ "biovar 4\n"
+ "biovar 4\n"
+ "biovar 3\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 1\n"
+ "biovar 2\n"
+ "biovar 2\n"
+ "biovar 2\n"
+ "biovar 2\n"
+ "biovar 2\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?\n"
+ "?";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}