#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*\n.*)"[^"]*","
Local $sString = ""abc" & @CRLF & _
"" & @CRLF & _
"de" & @CRLF & _
"f 123",123,456" & @CRLF & _
""asdf" & @CRLF & _
"ghj" & @CRLF & _
"" & @CRLF & _
"kl",789,100" & @CRLF & _
""asdfghjkl",000,900"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")