// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Acquired +: (.*) using.*").unwrap();
let string = "Acquired : Oct 29 2015 03:11:05 pm using AcqMethod OB102915.m";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}