package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\s*([^][|]*?)\s*\|[^][]*]`)
var str = `[ choice A | choice B ] and choose between [ choice D | choice F ]`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}