package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+(?:-+\w+){2,}`)
var str = `http://time.com/this----time-is-different`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}