use strict;
my $str = '123
9876456000
123456789
246
91370
3456
111
415263
xyz123xyz';
my $regex = qr/^\d*(0)1[23456789] | (0|1)2[3456789] | (0|1|2)3[456789] |(0|1|2|3)4[56789] | (0|1|2|3|4)5[6789] | (0|1|2|3|4|5)6[789] |(0|1|2|3|4|5|6)7[89] | (0|1|2|3|4|5|6|7)8(9)\d*$/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}