// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^\d*(0)1[23456789] | (0|1)2[3456789] | (0|1|2)3[456789] |(0|1|2|3)4[56789] | (0|1|2|3|4)5[6789] | (0|1|2|3|4|5)6[789] |(0|1|2|3|4|5|6)7[89] | (0|1|2|3|4|5|6|7)8(9)\d*$").unwrap();
let string = "123
9876456000
123456789
246
91370
3456
111
415263
xyz123xyz";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}