Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^\d+((,\d)?(-(\d+)?(,\d)?)?)?$
/
gm
Input 1
1
New
13,4 5,66876876 13,4-15,6 4-5 5 45 34,534 13,7-14 14-15,6 14-15,67 1,236 14,5-15 15-16,5 4,5-16,76 100,4 100,45 100,45-100,4 100,4-100,54 100,5-123323,5