import Foundation
let pattern = #"^\d+((,\d)?(-(\d+)?(,\d)?)?)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
13,4
5,66876876
13,4-15,6
4-5
5
45
34,534
13,7-14
14-15,6
14-15,67
1,236
14,5-15
15-16,5
4,5-16,76
100,4
100,45
100,45-100,4
100,4-100,54
100,5-123323,5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)