import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\w+(?:'\\w+)? ){0,2}WORDHERE(?: \\w+(?:'\\w+)?){0,2}";
final String string = "you're not WORDHERE is the best\n"
+ "the worst WORDHERE surely didn't win\n"
+ "not WORDHERE is the best";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}