Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?P<nested> \b if \b (?P<if>(?>.?(?>(?P>nested))?)*?) (?: \b elsif \b (?P<elsif>(?>.?(?>(?P>nested))?)*?) )? (?: \b else \b (?P<else>(?>.?(?>(?P>nested))?)*?) )? \b endif \b )?
/
ixs
Test String
New
if 1 if 2 elsif 2 else 2 if 3 endif 2 endif 1 if 2 else 2 endif 1 elsif 1_elsif1_ elsif 1_elsif2_ else 1_else_ endif