import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s)[^\\s]+$";
final String string = "[XIUREN秀人网] 2020.05.20 NO.2270 杨晨晨sugar\n"
+ "[UGIRLS尤果网] 2016.10.28 U221 杨晨晨\n"
+ "[YOUMI尤蜜荟] 媚眼传情 陈宇曦\n"
+ "[XIUREN秀人网] 2021.05.25 NO.3456 葛征 净高184cm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}