use strict;
my $str = '[XIUREN秀人网] 2020.05.20 NO.2270 杨晨晨sugar
[UGIRLS尤果网] 2016.10.28 U221 杨晨晨
[YOUMI尤蜜荟] 媚眼传情 陈宇曦
[XIUREN秀人网] 2021.05.25 NO.3456 葛征 净高184cm';
my $regex = qr/(?<=\s)[^\s]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}