#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\/(?:3[0-2]|[12]*\d),)*(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\/(?:3[0-2]|[12]*\d)$"
Local $sString = "192.168.1.1/0,255.255.255.255/32,10.10.10.10/24,0.0.0.0/24" & @CRLF & _
"192.168.1.1/32" & @CRLF & _
"192.168.1.1/0" & @CRLF & _
"192.168.1.1/33" & @CRLF & _
"192.168.1.1/01" & @CRLF & _
",192.168.1.1/24" & @CRLF & _
"192.168.1.1/24," & @CRLF & _
"192.168.1.1" & @CRLF & _
"/32"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")