import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\/(?:3[0-2]|[12]*\\d),)*(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\/(?:3[0-2]|[12]*\\d)$";
final String string = "192.168.1.1/0,255.255.255.255/32,10.10.10.10/24,0.0.0.0/24\n"
+ "192.168.1.1/32\n"
+ "192.168.1.1/0\n"
+ "192.168.1.1/33\n"
+ "192.168.1.1/01\n"
+ ",192.168.1.1/24\n"
+ "192.168.1.1/24,\n"
+ "192.168.1.1\n"
+ "/32";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}