$re = '/^(?:(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\/(?:3[0-2]|[12]*\d),)*(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\/(?:3[0-2]|[12]*\d)$/m';
$str = '192.168.1.1/0,255.255.255.255/32,10.10.10.10/24,0.0.0.0/24
192.168.1.1/32
192.168.1.1/0
192.168.1.1/33
192.168.1.1/01
,192.168.1.1/24
192.168.1.1/24,
192.168.1.1
/32';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);