re = /[0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}:[0-9]{1,4}/m
str = 'Proxy: <Proxy US 0.19s [HTTPS] 20.206.106.192:80>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end