# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^StartWord\R+\K.*?\R(?=\R*^StopWord\R)//gms;t' <<< "Delete this text De l e te this text
StartWord
Apples Oranges
Pears Grapes
StopWord
Delete this text Delete this text
StartWord
Peas Carrots
Peas Carrots
StopWord
Delete this text Delete this text
"