$re = '/\b\*\*\B/m';
$str = 'Th**is is a **text** test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);