#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w*?):[\d\D]*?xxx"
Local $sString = "test1:" & @CRLF & _
"Some random" & @CRLF & _
"multiline text herexxx" & @CRLF & _
"test2:" & @CRLF & _
"another multiline" & @CRLF & _
"Textxxx" & @CRLF & _
"value124:" & @CRLF & _
"again random Text" & @CRLF & _
"In multiple " & @CRLF & _
"linesxxx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")