re = /(\w*?):[\d\D]*?xxx/m
str = 'test1:
Some random
multiline text herexxx
test2:
another multiline
Textxxx
value124:
again random Text
In multiple
linesxxx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end