package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)value="(\d+),\s*(\d+),\s*(\d+),\s*(\d+)"`)
var str = `<classifier id="box-geometry" value="476,736,703,997" />
<classifier id="box-geometry" value="476,736,703, 997" />
<classifier id="box-geometry" value="476, 736, 703, 997" />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}