use strict;
my $str = '123-45-6789
123456789
001341343
888-03-1785
888-04-0001
666-23-1234
666231234
000-65-1343
000651343
905-31-6375
905316375
888-00-1785
888001785
888-04-0000
888040000
666-00-0000
666-01-4050';
my $regex = qr/^(?!666|000|9[0-9]{2})[0-9]{3}[-]?(?!00)[0-9]{2}[-]?(?!0{4})[0-9]{4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}