// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w+)[:=](\w+),?").unwrap();
let string = "key1=value1,key2=value2,key3=value3";
let substitution = "KEY: \\1, VALUE: \\2\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}