package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{0,}(\.{0,1}|,{0,1})\d{1,2}`)
var str = `
123,12333333333333,33333333333`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}