const regex = /^[a-zA-Z]$|^[a-zA-Z][a-zA-Z.\-']{0,78}[a-zA-Z']$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z]$|^[a-zA-Z][a-zA-Z.\\-\']{0,78}[a-zA-Z\']$', 'gm')
const str = `abc.'
abc-'.'
ab-.''-a
rish a
rish.-
a
a-
a-'
abc
-
'
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}