package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\b([AW|BW|AS]{2})(\d{4})`)
var str = `AW0001
AW0002
BW0001
BW0002
AS0001
BS0002
AW0001
AW0002
BW0001
BW0002
AS0001
BS0002
AG0002`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}