use strict;
my $str = 'AW0001
AW0002
BW0001
BW0002
AS0001
BS0002
AW0001
AW0002
BW0001
BW0002
AS0001
BS0002
AG0002';
my $regex = qr/\b([AW|BW|AS]{2})(\d{4})/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}