package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^google(?:\.(?:[a-z]{1,2}|[a-z]{4,}|[^c.\n][a-z]{2}|[a-z][^o.\n][a-z]|[a-z]{2}[^m.\n])|\.com\.(?:[a-z]|[a-z]{3,}|[^a.\n][a-z]|[a-z][^u.\n])|(?:\.[a-z]+){3})(?:\.[a-z]+)*$`)
var str = `google.co
google.org
google.uk
google.com.pk
google.co.uk
google.com
google.com.au`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}