const regex = /\s\[[^\]]+\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s\\[[^\\]]+\\]', 'gm')
const str = `Привет! Мой любимый [любимий] магазин - Таргет. Он находится в El Con центре [сентре] Тусоне. Вы [ви] можете купить практически [пратически] все, что вы хотите. Например, игрушки. Очень круто! Мужскую, женскую и даже детскую одежду. Вы также можете купить электронику и больше. Таргет - дешевый [дешевий] и дорогой магазин, но это только иногда дорог дорого. Мне нравится их одежда и симпатичные работники. Я иногда хожу в Таргет, и я думаю, что многим нравится ходить туда. Мужчинам, женщинам и детям. Здесь есть даже Старбакс и Pizza Hut.
<1:33>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);