using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[^\]\[]*\.png[^\]\[]*\]";
string input = @"[yo.png.loltha()##twaslaasdzy] [it gives you exactly] [what you asked] [for.png] [damn] [nic ehuh.png ]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}