package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^\]\[]*\.png[^\]\[]*\]`)
var str = `[yo.png.loltha()##twaslaasdzy] [it gives you exactly] [what you asked] [for.png] [damn] [nic ehuh.png ]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}