re = /\[[^\]\[]*\.png[^\]\[]*\]/m
str = '[yo.png.loltha()##twaslaasdzy] [it gives you exactly] [what you asked] [for.png] [damn] [nic ehuh.png ]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end