using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""?)key\1.*?""(.*?)""";
string input = @"blahblah ""key"":""value"",""TargetCRS"": ""Target"",""TargetCRScode"": ""vertical Code"",""zzz"": ""aaaa"" sadzxc ""sss""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}