$re = '/"key"\s*:\s*"((?:(?<!\\\\)\\\\(?:\\\\{2})*"|[^"])*)"/';
$str = 'blahblah "key":"\\\\\\"value\\"","TargetCRS": "Target","TargetCRScode": "vertical Code","zzz": "aaaa" sadzxc "sss"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);