using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^f(([ ]\d{1,2}(\/{0,2}\d{0,1})\/{0,1}){0,3})$";
string input = @"f 1 2 3
f 1/ 2/ 3/
f 1// 2// 3//
f 1/1 2/2 3/3
f 1/1/ 2/2/ 3/3/
f 1//1 2//2 3//3
f /1/ /2/ /3/
f 1/1/1 2/2/2 3//3
f 1/1 2/2 3/3 4/4
^f(([ ]\d{1,2}(\/{0,2}\d{0,1})\/{0,1}){0,3})$
[18:08, 20/11/2019] Jose Luis Uni
^f(([ ]\d+(\/{0,2}\d+))+)$
[18:30, 20/11/2019] Jose Luis Uni:
^f(([ ](\d+)(\/{0,2}\d+))+)$
^f(([ ](\d+)(\/{0,2}\d*))+)$
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}