re = /(?m)^HFT-(.+?)\h+.+$/
str = 'HFT-COOL (Surf) - Codingweb
HFT-SURFER (Surf) - Codingweb'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result