#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))"
Local $sString = "$a, $b, $c, $hi = "", $na"
Local $sSubst = " = NULL"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)